Failing application deployments
Resolved
Sep 14, 2026 at 12:21pm UTC
Git deployments are starting normally again. Image pulls through our Frankfurt workers were slow overnight and this morning, which made some deploys show "Application start failed" even after a successful build. That path is back to normal.
If a deploy still hits that error, retry it. If it keeps failing, contact support.
Affected services
Created
Sep 14, 2026 at 10:54am UTC
Degraded performance (running apps are fine)
Some deployments are failing with "Application start failed" even when the build succeeds. Image pulls are taking much longer than usual, so the new version does not start within the normal wait time. It may still come up later.
Applications that are already running are not affected.
We are working on a fix. If you need to deploy now, retry later or contact support.
Affected services